Prebid Analytics Integration Guide

This feature is in BETA. Reach out to your account manager for more information.


0. Prerequisites

You must update to Prebid.js version 2.11.0 or later to access the Sortable adapter. If you are not planning to update to this version, please speak to your Sortable account manager.

1. Sortable Account Setup

Publisher provides Sortable with:

A list of sites you wish to integrate the adapter on, and for each, we need the domains you serve on (for example, example.com).

Sortable provides the publisher with:

The siteId for each site to use in the adapter

2. Adapter Configuration

2.1 Set up and enable the Analytics adapter

Add the Sortable configuration in a pbjs.que.push block using the provided siteId.

Prebid 2.11
pbjs.que.push(function() {
    pbjs.enableAnalytics({
        provider: 'sortable',
        options: {
            siteId: 'example.com'
        }
    });
});

3. Change Log

Prebid.js VersionComment
2.11.0Sortable Adapter Added